Perapera-kun 2.0 Now Live on Mozilla!

Mozilla has finally got around to approving the new version after sitting 2 weeks in the queue. So for those who haven’t yet, here is the link the pages on the mozilla add-ons site where you can download and install the latest version. Although the Japanese and Chinese versions have now become 1 plugin, I left them both up on separate pages so people who already had them installed would get the update automatically.

I have already been working on the next release, so look for that to appear in the box.net download section on this blog soon (alot sooner than the time between the last update, I promise!! hehe) Since it takes mozilla around 2 weeks to approve, you’ll have it that much sooner from here. Enjoy!

Perapera-kun 2.0:
https://addons.mozilla.org/en-US/firefox/addon/3343 or
https://addons.mozilla.org/en-US/firefox/addon/3349

How to install and use

http://perapera.wordpress.com/perapera-kun
http://perapera.wordpress.com/chinese/

10 thoughts on “Perapera-kun 2.0 Now Live on Mozilla!

  1. The version 2.0 upgrade works great with Firefox, but when trying to install the .XPI file on Thunderbird 2.0.0.23, I get the following odd screen formatting:

    http://www.screencast.com/t/YTBkZWM4Y

    and the following errors logged to the Error Console:

    Warning: Failed to load overlay from chrome://perakun/content/thunderbird/tb-overlay.xul.
    Source File: chrome://messenger/content/messenger.xul
    Line: 0

    Error: not well-formed
    Source File: chrome://perakun/content/thunderbird/tb-overlay.xul
    Line: 8, Column: 4
    Source Code:
    ————-^

    Warning: Warning: Unrecognized chrome registration modifier ‘contentaccessible=yes’.
    Source File: file:///U:/ThunderbirdPortable/Data/profile/extensions/chineseperakun@gmail.com/chrome.manifest
    Line: 2

    • It worked on an older version of thunderbird I had it installed on. I’ll try fixing it for the new version. Do alot of people use this on thunderbird? I was thinking to remove this function

      Sent from my iPhone

      • Perapera-kun 1.05 used to work with Thunderbird and I did use it occasionally when receiving e-mail from my colleagues in Hong Kong and Japan. I suppose it’s not as urgent as support for Firefox, especially since this is aimed at education, but I do enjoy it working in Thunderbird as well.

        Thanks Justin!

      • yeah, I also can not install it on Thunderbird 2.0.0.23 (20090812). It said that the addons is not for the TB.

        Should I need use older Perapera-kun (v.1.05) rather than newer one?

        Thanks JustinK and VG.

  2. I uninstalled version 2.0 and went back to version 1.05. I actually couldn’t even figure out to get 2.0 to work. I much prefer the simple pop-up functionality of 1.05 and being able to turn it on and off via menu on right click.

  3. I’m curious to know why there is two different Perakun 2.0 or the same if not. For Chinese and Japanese that is. When I go to install it acutally does install both but its the same title and everything. Any reason for the change/difference? I thought it already could do Jpn/Cn/Krn already.

  4. Justin, I thank you very very much for your effort in keeping perapera-kun (Chinese) updated for Firefox however I did use to use it a lot also in Thunderbird. Now with Thunderbird 3.0 the new version 2.0 plugin installs but does not show anywhere (either status bar or in the tools menu).
    Please do keep the Thunderbrid compatibility!!

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>